Unresponsive PowerShell in WIndows Server 2022

Viewing 1 reply thread
  • Author
    Posts
    • #1567664
      PowerMe!
      Participant
      Member Points: 1,786
      Rank: 3

      Hi all,

      I have a strange issue with PowerShell. All forms of access take a long time (~5 min) to load. The window stays in a partially open state as in the screenshot.

      1. PowerShell 5.1, 7
      2. PowershelISE
      3. PowerShell launched from the CLI

      I tried to remove it from Server Manager and restart. I wonder how to troubleshoot this.

       

      unresponsive powershell windows.

    • #1567687
      Surender Kumar
      Participant
      Member Points: 6,980
      Rank: 3

      I would start by typing the following command in the Run dialog:

      powershell -noprofile

      If it loads instantaneously, the problem is indeed in the PS profiles that are loaded at launch. Also try adding the PowerShell executable to the Windows Defender exclusions.

      avatar
      • #1567739
        PowerMe!
        Participant
        Member Points: 1,786
        Rank: 3

        Thanks Surender.

        I thought it was a profile issue and tried that earlier- no help.

        I even added Windows PowerShell to the exclusion in defender, no help.

        Its a lab machine where I had my Hyper-v server – I could refresh it but wanted to know the issue in case it affects a production server.

         

Viewing 1 reply thread
  • You must be logged in to reply to this topic.
© 4sysops 2006 - 2022

CONTACT US

Please ask IT administration questions in the forums. Any other messages are welcome.

Sending

Log in with your credentials

or    

Forgot your details?

Create Account