/PrepareAD cannot modify AD objects and Exchange 2013 upgrade fails

Share
Viewing 1 reply thread
  • Author
    Posts
    • #1376070
      Reiko
      Participant
      • Topics: 1
      • Replies: 0
      Post count: 1
      Member Points: 60
      Rank: Level 1

      I am trying to upgrade Exchange 2007 to Exchange 2013.

      Our environment:

      • AD: Windows Server 2008 R2 SP1.
      • Echange 2007: Windows Server 2003 R2 SP2.
      • Exchange 2013: Windows Server 2012 R2.

      The procedure is performed in a test environment on a backup server.
      PrepareSchema runs without any problems and the configuration objects have ex13cu23 level attributes. But when I run /prepareAD, the fun begins. It simply cannot modify objects. In the logs you see ALL objects that are affected during the installation.

      /PrepareAD aborts with with this error

      Microsoft.Exchange.Data.InvalidObjectOperationException: The RoleFlags property cannot be set for this object, because the version of the object must be at least 0.10 (14.0.100.0). The current version of the object is 0.1 (8.0.535.0)

      I think it’s strange because it seems that /prepareAD must raise the version. And if you change the version of the attribute manually (on hundreds of objects, huh), then it claims that they are all Read-Only.

      And here it seems to me that the problems is about permissions.

      The user from which we perform the installation has the following rights: Domain Admin, Schema Admin, Enterprise Admin, organization management, Exchange Organization Administrators1, Exchange Install Domain Servers (well, what if).

      I am grateful for any ideas, I’ve been fighting for a week. Since I am working on a backup, I tried to delete the problematic objects in ADSI and  /prepareAD then creates new ones. Everything is cool, but they need to be deleted (renamed) manually, and there are a lot of them. It seems to me, Exchange 2007 will not work anymore after such manipulations. This was done for fun in order to see what happens. I’m not going to do this in my main environment.

      Any advice is appreciated!

      0
    • #1516498
      IT Engineer
      Participant
      • Topics: 5
      • Replies: 5
      Post count: 9
      Member Points: 416
      Rank: Level 2

      There are some ways to do it differently:

      1. Logon to the Domain Controllers with the Schema Master role.
      2. Make sure the login account is part of the Enterprise Admins, Organization Management  & Schema Admins AD group.
      3. Right Click, then Run as Administrator on the cmd. prompt.

      Then let us know how it goes.

      0
Viewing 1 reply thread
  • You must be logged in to reply to this topic.
© 4sysops 2006 - 2020

CONTACT US

Please ask IT administration questions in the forums. Any other messages are welcome.

Sending

Log in with your credentials

or    

Forgot your details?

Create Account