This topic is resolved

Share

This topic contains 8 replies, has 2 voices, and was last updated by  Karim Buzdar 3 weeks, 6 days ago.

  • Author
    Posts
  • #294223
     Karim Buzdar 
    Moderator
    • Topics: 24
    • Replies: 79
    Post count: 248
    Member Points: 5,980
    Rank: Level 1

    Hi all,

    I was changing user’s mailbox password in Exchange 2016 from PowerShell but I am getting following error. I have tried different passwords thrice.

    “The password you entered doesn’t meet the minimum security requirements”

    I have disabled the “Password must meet complexity requirements” policy from GP management in AD server.

    Please help.

    Thank you,

    0
  • #294250
     Michael Pietroforte 
    Keymaster
    • Topics: 138
    • Replies: 331
    Post count: 1022
    Member Points: 6,809
    Rank: Level 1

    Is this the Default Domain Policy? Can you set this password in ADUC on the Primary Domain Controller?

    0
    • #294262
       Karim Buzdar 
      Moderator
      • Topics: 24
      • Replies: 79
      Post count: 248
      Member Points: 5,980
      Rank: Level 1

      Michael,

      Yes, this is default domain policy. I can set this password in ADUC on the Primary Domain Controller.

      Thank you,

      0
  • #294268
     Michael Pietroforte 
    Keymaster
    • Topics: 138
    • Replies: 331
    Post count: 1022
    Member Points: 6,809
    Rank: Level 1

    Hmm, strange. Maybe you have a syntax error somewhere. The screenshot doesn’t show the entire command.

    0
    • #294284
       Karim Buzdar 
      Moderator
      • Topics: 24
      • Replies: 79
      Post count: 248
      Member Points: 5,980
      Rank: Level 1

      Don’t know what’s causing the error.

      Following is the complete command.

      Set-Mailbox -Identity “karim buzdar” -OldPassword (ConvertTo-SecureString -string “@pass1” -AsPlainText -Force) -NewPassword (ConvertTo-SecureString -string “@pqwert2” -AsPlainText -Force)

      Thank you,

      0
  • #294287
     Michael Pietroforte 
    Keymaster
    • Topics: 138
    • Replies: 331
    Post count: 1022
    Member Points: 6,809
    Rank: Level 1

    Looks correct to me. Maybe you try to read the passwords with Read-Host ($password = Read-Host “Enter password” -AsSecureString). I would also try to reboot all involved machines and check if the policy is really active (gpresult). You can also try the -Password parameter instead of -NewPassword and -OldPassword. Maybe it helps you to figure out what went wrong.

    0
    • #299828
       Karim Buzdar 
      Moderator
      • Topics: 24
      • Replies: 79
      Post count: 248
      Member Points: 5,980
      Rank: Level 1

      Thank you Michael,

      I have read the passwords with Read-Host but getting the same error. Don’t know, whats happening.

      0
  • #299889
     Michael Pietroforte 
    Keymaster
    • Topics: 138
    • Replies: 331
    Post count: 1022
    Member Points: 6,809
    Rank: Level 1

    Really strange. You could also try the Active Directory module.

    0
  • #301389
     Karim Buzdar 
    Moderator
    • Topics: 24
    • Replies: 79
    Post count: 248
    Member Points: 5,980
    Rank: Level 1

    OK,

    0

You must be logged in to reply to this topic.

CONTACT US

Please ask IT administration questions in the forum. Any other messages are welcome.

Sending
© 4sysops 2006 - 2017

Log in with your credentials

or    

Forgot your details?

Create Account