Viewing 21 reply threads
  • Author
    Posts
    • #1561287
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      I am currently testing a dark theme for logged-in users. If use a dark theme on your computer, the dark theme will be enabled after you log in. You can change themes through the switch on the left bottom. Please note that this only a test. I am unsure if we can keep this feature.

      I also changed the design of the light theme a little.

      Please let me know what you think.

      +2
      avataravatar
    • #1561288
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Interesting test and nice theme, I think is a good improvement, it is also more actractive with round windows boxes.

      I like the switch to activate/disactivate dark theme. About online active members, in my opinion it is better replace current white icon with a something else for users without a picture profile.

       

      0
    • #1561289
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      Paolo, thanks! There are still a few issues with the colors. I have to see first if this isn’t too time consuming. With every update there are CSS changes and that might cause incompatibilities with the dark theme.

      There also is a problem with the plugin. If you load a new page, you always see the white theme for a fraction of a second. I posted in their forum. Let’s if they will fix this.

      0
    • #1561290
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Not a big issue, there is also the filter is not really readable (grey on white background) :

       

      0
    • #1561291
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      Thanks! I will take a look at this once I know if we can keep this feature.

      +1
      avatar
    • #1561311
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Another cosmetic problem … the link is pretty dark to read it

      0
      • #1561312
        Michael Pietroforte
        Keymaster
        Member Points: 31,673
        Author of the year 2018
        Rank: 4

        Yeah, the plugin has problems with JavaScript. I have to wait until the developers reply to see if it makes sense to keep this.

         

        0
    • #1561313
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Maybe it is not related to this theme refresh, but monthly stats are not updated.

      0
    • #1561314
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Here another little adjustment to do about social icons.

       

      0
    • #1561315
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      Paolo, thanks, but it is too early to look into all those details because I don’t even know if we can keep this feature.

      +1
      avatar
    • #1561316
      Vignesh Mudliar
      Participant
      Member Points: 2,287
      Rank: 3

      I love this theme. Dark mode 👍🏼

      +1
      avatar
    • #1561445
      Leos Marek
      Moderator
      Member Points: 22,560
      Author of Year 2020
      Rank: 4

      Hi Michael,

      looks good. The thing with the color change is a bit weird for now…

      Also – the comment box that Im using now is still white. Its a bit shiny when everything else is dark 🙂

      Cheers

      0
    • #1561446
      Leos Marek
      Moderator
      Member Points: 22,560
      Author of Year 2020
      Rank: 4

      Also, the icons of author and member of the year – the blue bold text looks strange in dark theme 🙂

      But I guess this is something hard to solve.

      0
    • #1561449
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      The developers did not react to my forum post about the color change. This means that they aware of the issue but don’t really care. When I have more time I will look for another plugin. In any case, I can only offer limited support for minor color incompatibles. With any update new incompatibles can come up and it would be too time consuming to always fix these issues. There are currently only very few members who use the dark theme.

      0
    • #1561467
      Leos Marek
      Moderator
      Member Points: 22,560
      Author of Year 2020
      Rank: 4

      Hi Michael,

      seems the member monthly board was not updated for several days now.

      CHeers

      0
      • #1561468
        Michael Pietroforte
        Keymaster
        Member Points: 31,673
        Author of the year 2018
        Rank: 4

        It looked updated to me, but I cleared the cache now.

        0
        • #1561469
          Leos Marek
          Moderator
          Member Points: 22,560
          Author of Year 2020
          Rank: 4

          Weird, I still see 185 while it should be much more if I check the points directly:)

          0
        • #1561470
          Michael Pietroforte
          Keymaster
          Member Points: 31,673
          Author of the year 2018
          Rank: 4

          You have 410 points this month.

          0
    • #1561730
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Hi Michael,
      there are some feature not working after dark theme removal. For example, add a News or filter on site-wide page.
      But I think you are still working on template refresh…

      Paolo

      0
      • #1561731
        Michael Pietroforte
        Keymaster
        Member Points: 31,673
        Author of the year 2018
        Rank: 4

        We had some major issues and I had to disable a few plugins for troubleshooting. However, it seems the issue was caused by AWS because the problem also occurred in older backup instances. Everything appears to back to normal. Let me know if some features are still not working.

        0
        • #1561732
          Paolo Maffezzoli
          Participant
          Member Points: 60,412
          4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
          Rank: 4

          ok, thanks for your update.. Now it is running fine and In don’t see any other issues.

          0
    • #1561733
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Now the dark theme is not enabled changing page. This setting is lost also if forcing a refresh or changing browser.

      0
      • #1561734
        Michael Pietroforte
        Keymaster
        Member Points: 31,673
        Author of the year 2018
        Rank: 4

        I can’t replicate this. Did you try to clear the browser cache?

        0
        • #1561735
          Paolo Maffezzoli
          Participant
          Member Points: 60,412
          4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
          Rank: 4

          Yes, cache already cleaned.. I have the same behaviour with different browsers Edge, Chrome and Firefox.

          0
        • #1561736
          Michael Pietroforte
          Keymaster
          Member Points: 31,673
          Author of the year 2018
          Rank: 4

          So you can’t enable the dark theme when you are logged in? Do you see the switch button at the lower left?

          0
        • #1561738
          Paolo Maffezzoli
          Participant
          Member Points: 60,412
          4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
          Rank: 4

          Yes, switch button is shown and I can switch to the dark theme only in the current page.

          Remaining in the same page the dark theme is correct but when I move to another page the theme return to normal theme.  Of course I can switch again to dark theme but this behavier is the same for every page.

          0
        • #1561739
          Michael Pietroforte
          Keymaster
          Member Points: 31,673
          Author of the year 2018
          Rank: 4

          That’s strange. I can’t replicate this. I tried several browsers. Maybe you are blocking cookies?

          0
        • #1561761
          Paolo Maffezzoli
          Participant
          Member Points: 60,412
          4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
          Rank: 4

          Just tried to another devices, I don’t see this issue on iPad , instead another PC has the same behaviour also with adblocker disabled.

          0
        • #1561762
          Michael Pietroforte
          Keymaster
          Member Points: 31,673
          Author of the year 2018
          Rank: 4

          You are right. The problem only exists on Windows. I restored an earlier version that doesn’t have the problem. It should work now.

          +1
          avatar
    • #1561952
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      Hi Michael,

      just few thoughts about the dark theme. In my opinion when activated is more relaxing and readable. It is a nice way to browse the site, it helps to concentrate to the site content.  What is you opinion about the dark theme feature? Based on your tests, do you plan to keep it?

       

      0
    • #1561955
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      For now we can keep it. I don’t like that the page turns white when you open a new page. It is a problem of the plugin. But the other plugins I tried have other problems.

      0
      • #1561956
        Paolo Maffezzoli
        Participant
        Member Points: 60,412
        4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
        Rank: 4

        Thanks for the update, I agree about the issue about page turns white but it is only an annoying issue not a real problem. BTW I appreciate the Related Articles box at the end of each artcile. In the latest theme update was disappeared.

        +1
        avatar
    • #1562164
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      The template has been updated?

      0
      • #1562165
        Michael Pietroforte
        Keymaster
        Member Points: 31,673
        Author of the year 2018
        Rank: 4

        I made some changes. Something not working?

        0
        • #1562166
          Paolo Maffezzoli
          Participant
          Member Points: 60,412
          4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
          Rank: 4

          It is ok, it is only missing the Related Articles box at the end of blog articles. Did you plan to permanently remove it?

          0
        • #1562167
          Michael Pietroforte
          Keymaster
          Member Points: 31,673
          Author of the year 2018
          Rank: 4

          It caused some issues with Google’s Core Web Vitals. I might add it again later. But Google has to crawl the entire site first.

          0
        • #1562197
          Paolo Maffezzoli
          Participant
          Member Points: 60,412
          4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
          Rank: 4

          ok, thanks.

          0
    • #1562250
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      I am sorry, I had to disable the dark mode plugin now because it totally crashed the site twice.

      0
    • #1562251
      Paolo Maffezzoli
      Participant
      Member Points: 60,412
      4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
      Rank: 4

      There is something still not working. I can access only on my mobile browser.

      0
    • #1562252
      Michael Pietroforte
      Keymaster
      Member Points: 31,673
      Author of the year 2018
      Rank: 4

      Paolo, thanks. It should be working now.

      +1
      avatar
      • #1562253
        Paolo Maffezzoli
        Participant
        Member Points: 60,412
        4sysops member of the year 2018Member of the Year 2019Member of the Year 2020
        Rank: 4

        Now it is working fine.  Thanks!

        +1
        avatar
Viewing 21 reply threads
  • You must be logged in to reply to this topic.
© 4sysops 2006 - 2021

CONTACT US

Please ask IT administration questions in the forums. Any other messages are welcome.

Sending

Log in with your credentials

or    

Forgot your details?

Create Account